It is currently Sun Jan 26, 2020 9:37 pm
Board index » Talking About Stuff » Suzuki Talk



Post new topic Reply to topic  [ 5 posts ] 
Author Message

Offline
az supporter
az supporter
User avatar

Joined: Sun Jan 26, 2014 9:33 am
Posts: 154
Location: Leschenault, WA.
Vehicle: SJ51 LWB

Post Posted: Sun Jan 12, 2020 10:38 pm 
Reply with quote Top  
So long story short, mate gives me a ring, daughters car made a chunk chunk noise while on freeway, engine smelt like oil, made a rattle and died.

Got said mate to get it towed to mine, i'll see if I can sort it while he's away FIFO. Daughter drops it off, explains what happens. While it's getting released off the trailer, its dropping oil like a land rover all over the floor.

Pop bonnet, radiator empty, overflow full, pull dipstick, oil smells of popcorn. Pull plugs, every ones covered in coolant, tips are pure white. Have a look under, bulk oil pooling from the rear main, not sure where the rest of the oil was from, but all the rubbers for the plugs were melted, the timing cover had melted. Put it in neutral, Tried to turn it over with a breaker bar, it's completely seized, informed dad and he sourced her another motor.

As I started pulling the old one out, I tore off the intake etc as there was oil right down to the airbox all over the filter.

Here's some pics.

Image
Image
Image

while getting it stripped down even more, noticed a lot of corrosion/ build up all through the throttle body, intake manifold, the whole thermostat was clogged, and none of the sensors were touching water.

Image
Image

So stripped the engine out of the bay, got him to basically order enough shit to completely spruce up the other motor he got, a new rad, hoses usual consumables.

after a decent bath, complete strip down, the intake side is now pretty good.

Image

We pulled the new motor down, gave the block and head a good clean, checked some specs, all looks hunky dory, threw a new head gasket, water pump, timing belt, thermostat, plugs, idler, front and cam seals at it while it was all apart.

Image
Image

now just got to time it up, throw the rest of the ancillaries on, and put it back in the car when he gets back on his next rnr.

Image

It's been good playing with little g16bs again.

Oh, the cause of the failure, the heater return hose on the back of the head split to the heater core. All the hoses were despairingly perished, when she got sold the car she got the usual story of a little old lady owning it, and a mechanic in the town next to us always looked after the car for her.

Pete.

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Sat Oct 06, 2012 6:19 pm
Posts: 1849
Vehicle: Sierras!! SWB and LWB

Post Posted: Sun Jan 12, 2020 11:53 pm 
Reply with quote Top  
Cripes! That was an absolute mess!! Perfect job of killing the motor and an even better job of resurrection! You thinking of coming back to the Suzuki side? Hehe

 Profile  

Offline
I live here!
I live here!
User avatar

Joined: Sun Jul 05, 2009 12:00 am
Posts: 42842
Location: Rockingham W.A
Vehicle: SQ625

Post Posted: Mon Jan 13, 2020 12:25 am 
Reply with quote Top  
Fucked it good and proper :oops!:

_________________
Joe likes boobs

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Sun Jan 26, 2014 9:33 am
Posts: 154
Location: Leschenault, WA.
Vehicle: SJ51 LWB

Post Posted: Mon Jan 13, 2020 7:03 am 
Reply with quote Top  
bumstein wrote:
Cripes! That was an absolute mess!! Perfect job of killing the motor and an even better job of resurrection! You thinking of coming back to the Suzuki side? Hehe



Not to Suzuki, but have been thinking of selling my jeep for the last month or so and leaving 4wd'ing altogether.

Basically, she got from Usher to the Caltex servo just after Mandurah when it let go. No change in temp on the gauge and engine didn't throw any lights. I checked the ECU and there was no codes stored either.

 Profile  

Offline
az supporter
az supporter
User avatar

Joined: Sat Oct 06, 2012 6:19 pm
Posts: 1849
Vehicle: Sierras!! SWB and LWB

Post Posted: Mon Jan 13, 2020 10:22 am 
Reply with quote Top  
rexhunta wrote:
been thinking of selling my jeep for the last month or so and leaving 4wd'ing


Nooooooooooooooooooooooooooo!!

 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

Jump to:  


Who is online

Users browsing this forum: Alan, Eddy, zook-cruiser and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
Untitled Document


Untitled Document


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group :: Style based on FI Subice by phpBBservice.nl :: All times are UTC + 10 hours